Changes between Version 67 and Version 68 of Records/OverloadedRecordFields/Implementation
- Sep 17, 2013 3:12:56 PM (19 months ago)
v67 v68 248 248 == To do == 249 249 250 * Add `HsVarOut RdrName id` instead of `HsSingleRecFld` (or perhaps rename `HsVar` to `HsVarIn`)? 251 * This would also be useful to recall how the user referred to something. 252 * Is it worth generating all the derived names early, to get rid of `tcg_dfun_n`? 253 250 * Where should `TcBuiltInSynFamily` live? Could it be a fixed enumeration? 254 251 * Is `TcInstDcls.tcFldInsts` correct in its use of `simplifyTop` and assuming there will be no `ev_binds`? 255 256 * Consider syntactic sugar for `Upd` constraints. 257 * Improve unsolved `Accessor p f` error message where `p` is something silly? 258 252 * Consider defaulting `Accessor p` to `p = (->)`, and defaulting `Has r "f" t` constraints where there is only one datatype with a field `f` in scope. 259 260 * Document the extension. 261 * Tidy up code, comment, remove unused imports. 253 * We could add `HsVarOut RdrName id` instead of `HsSingleRecFld` (or perhaps rename `HsVar` to `HsVarIn`). This would also be useful to recall how the user referred to something. 254 * Add syntax for record projection? When we have explicit type application, one might be able to use `field @"foo"` or `getField @"foo"`.