Changes between Version 63 and Version 64 of Records/OverloadedRecordFields/Implementation


Ignore:
Timestamp:
Sep 4, 2013 3:44:04 PM (8 months ago)
Author:
adamgundry
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • Records/OverloadedRecordFields/Implementation

    v63 v64  
    240240 
    241241 
    242 == Outstanding bugs == 
    243  
    244 * typechecker/should_fail/tcfail102 (changed error message) 
    245  
    246  
    247242== To do == 
    248243 
    249 * Add `HsVarOut RdrName id` instead of `HsSingleRecFld` (or perhaps rename `HsVar` to `HsVarIn`)? This would also be useful to recall how the user referred to something. 
    250  
    251 * Haddock omits fields from HTML index and prints selector names in LaTeX exports list. 
     244* Add `HsVarOut RdrName id` instead of `HsSingleRecFld` (or perhaps rename `HsVar` to `HsVarIn`)? 
     245  * This would also be useful to recall how the user referred to something. 
     246 
     247* Haddock omits fields from HTML index and prints selector names in LaTeX exports list and Hoogle output. 
    252248 
    253249* When there is only one thing in scope, what should we do? See [wiki:Records/OverloadedRecordFields/Plan#Scopeissuesorwhywemissdot discussion here]. 
    254250* Is the story about `-fwarn-unused-binds` okay? 
    255251* Is `TcInstDcls.tcFldInsts` correct in its use of `simplifyTop` and assuming there will be no `ev_binds`? 
     252* Is it worth generating all the derived names early, to get rid of `tcg_dfun_n`? 
    256253 
    257254* Consider syntactic sugar for `Upd` constraints. 
     
    260257 
    261258* Document the extension. 
     259* Tidy up code, comment, remove unused imports.