Changes between Version 5 and Version 6 of Commentary/Packages/PackageCompatibilityProposal


Ignore:
Timestamp:
Oct 25, 2007 12:27:48 PM (6 years ago)
Author:
simonmar
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • Commentary/Packages/PackageCompatibilityProposal

    v5 v6  
    102102how are we to know if we should use base-2.x or base-3.x. It may be that this package has been updated to work with base-3.x or that it only ever used the parts of base-2.x that were not split off. This dependency does not provide us with enough information to know which to choose. So we are still left with the situation that every package must be updated to specify an api version of base. 
    103103 
    104 One possible remedy would be to call version 3 something other than base.  Any dependency on 'base' would refer to the set of modules that comprise base-2.x. 
     104One possible remedy would be to call version 3 something other than base.  Any dependency on 'base' would then refer to the set of modules that comprise base-2.x (this is (4.2) above, incedentally).