Changes between Version 9 and Version 10 of Commentary/Packages/MultiInstances


Ignore:
Timestamp:
Mar 23, 2012 12:01:24 AM (2 years ago)
Author:
duncan
Comment:

note that we need to be able to specify package instance in Setup.hs configure

Legend:

Unmodified
Added
Removed
Modified
  • Commentary/Packages/MultiInstances

    v9 v10  
    1818 
    1919 * GHC: allow specifying a package instance in the -package flags 
    20    * SDM: already done 
     20   * SDM: already done (-package-id flag) 
     21   * DC: already used by Cabal 
     22 
     23 * Cabal: allow specifying a package instance when doing Setup.hs configure 
     24   * DC: currently only == version constraints can be used, not installed package id. Shouldn't be too hard to add however. 
    2125 
    2226 * instances of packages must install in a different location