Changes between Version 6 and Version 7 of Building/Windows/Cygwin


Ignore:
Timestamp:
Nov 29, 2011 8:33:08 PM (4 years ago)
Author:
igloo
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • Building/Windows/Cygwin

    v6 v7  
    441. Install [http://www.cygwin.com/ Cygwin] 
    55 
    6 2. You must install enough Cygwin ''packages'' to support building GHC.  If you miss out any of these, strange things will happen to you.   There are two ways to do this: 
    7  * The direct, but laborious way is to select all of the following packages in the installation dialogue: 
    8    {{{cvs}}},  
     62. You must install enough Cygwin ''packages'' to support building GHC. This means selecting at least the following packages in the installation dialogue: 
     7   {{{git}}},  
    98   {{{openssh}}}, 
    109   {{{autoconf}}}, 
    1110   {{{binutils}}}, 
    1211   {{{gcc}}}, 
    13    {{{flex}}}, 
    1412   {{{make}}}. 
    1513   To see these packages, click on the "View" button in the "Select Packages" stage of Cygwin's installation dialogue, until the view says "Full".  
    16  * The clever way is to point the Cygwin installer at the 
    17    {{{ghc-depends}}} package, which is kept at [http://haskell.org/ghc/cygwin]. When the Cygwin installer asks you to "Choose a Download Site", choose one of the offered mirror sites; and then type "http://haskell.org/ghc/cygwin" into the "User URL" box and click "Add"; now two sites are selected. (The Cygwin installer remembers this for next time.) Click "Next". In the "Select Packages" dialogue box that follows, click the "+" sign by "Devel", scroll down to the end of the "Devel" packages, and choose {{{ghc-depends}}}. 
    1814 
    19153. Now set the following user environment variables: