Changes between Version 38 and Version 39 of Building/Troubleshooting


Ignore:
Timestamp:
Jul 20, 2013 7:44:03 PM (2 years ago)
Author:
rrnewton
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • Building/Troubleshooting

    v38 v39  
    430430There was another GCC on the system however (4.3.3). Using that version did allow GHC to build.
    431431
    432 
     432=== git is too old ===
     433
     434On RHEL6 systems, I have git 1.7.1 by default.  On such a system, `./sync-all --testsuite get` will fail with this error:
     435
     436{{{
     437warning: ghc-tarballs already present; omitting                                                                                                                                       
     438== ghc-tarballs: running git config --local core.ignorecase true                                                                                                                      error: unknown option `local'
     439}}}
     440
     441Building a newer version of git fixes the problem.
     442
     443