Changes between Version 6 and Version 7 of Building/Prerequisites


Ignore:
Timestamp:
Jun 18, 2008 1:38:20 PM (7 years ago)
Author:
simonmar
Comment:

add list of linux packages required for building, and mention python

Legend:

Unmodified
Added
Removed
Modified
  • Building/Prerequisites

    v6 v7  
    111111  OK. Others are probably OK too (assuming we don't create too
    112112  elaborate configure scripts.)
     113
     114 Python::
     115  Required for [wiki:Building/RunningTests running the testsuite].
     116  Version 2.5.2 or later is preferred, because you'll get support for
     117  running the testsuite in parallel.
     118
     119== Preparing a Linux system ==
     120
     121If you're on a recent Linux system, then you should be able to get a working build environment by installing the following packages using your system's package manager:
     122
     123 * glibc-devel
     124 * autoconf
     125 * automake
     126 * gcc
     127 * gmp-devel
     128 * make
     129 * perl
     130 * python
     131
     132other packages that are useful for development:
     133
     134 * strace