Changes between Version 3 and Version 4 of Building/Prerequisites


Ignore:
Timestamp:
Oct 6, 2006 10:14:16 AM (9 years ago)
Author:
simonmar
Comment:

wibbles to automake/autoconf

Legend:

Unmodified
Added
Removed
Modified
  • Building/Prerequisites

    v3 v4  
    8787  [http://www.haskell.org/alex/ Alex's Web Page].
    8888
    89  {{{automake}}}::
    90   GNU automake is needed if you intend to build using
    91   "./autoreconf". Version 1.9 works.
    92 
    93  {{{autoconf}}}::
    94   GNU autoconf is needed if you intend to build from the
    95   darcs sources, it is ''not'' needed if you
     89 {{{autoconf}}} and {{{automake}}}::
     90  These are needed if you intend to build from the
     91  darcs sources, they are ''not'' needed if you
    9692  just intend to build a standard source distribution.
    9793  [[br]][[br]]
    9894  Version 2.52 or later of the autoconf package is required.
    9995  NB. version 2.13 will no longer work, as of GHC version
    100   6.1.
     96  6.1.  Version 1.9 of automake is known to work, use others at
     97  your own risk.
    10198  [[br]][[br]]
    10299  {{{autoreconf}}} (from the autoconf package)
     
    108105
    109106 {{{sed}}}::
    110   You need a working {{{sed}}} if you are
    111   going to build from sources.  The build-configuration stuff
    112   needs it.  GNU sed version 2.0.4 is no good!  It has a bug
     107  Most Unix installations and Cygwin/MSYS on
     108  Windows already come with `sed`, so you're probably OK.
     109  GNU sed version 2.0.4 is no good!  It has a bug
    113110  in it that is tickled by the build-configuration.  2.0.5 is
    114111  OK. Others are probably OK too (assuming we don't create too