Changes between Version 20 and Version 21 of Building/Prerequisites


Ignore:
Timestamp:
Oct 10, 2008 5:25:05 AM (6 years ago)
Author:
judah
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • Building/Prerequisites

    v20 v21  
    130130 [http://www.thrysoee.dk/editline/ libedit]:: 
    131131  If libedit is installed, ghci will be built with a nice interactive line-editing interface.   
    132   Version 2.6.9 and later are known to work; note that the libeditline package listed on some distros is too old. [[br]][[br]] If your installation does not have libedit by default, you may either download and build it yourself from the link above, or else install your distro's relevant package (sometimes called "libedit-devel" or "libedit-dev"). 
     132  Version 2.6.9 and later are known to work; note that the libeditline package listed on some distros is too old. 
     133  If a suitable version of libedit cannot be found, ghc/ghci will still build fine, just without the nice line-editing capabilities. 
     134  [[br]][[br]] If your installation does not have libedit by default, you may either download and build it yourself from the link above, or else install your distro's relevant package (sometimes called "libedit-devel" or "libedit-dev"). 
    133135 [[br]][[br]]GHC does not use libedit on Windows; instead, it uses the console's default line editor. 
    134136== Preparing a Linux system ==