Changes between Version 4 and Version 5 of Building/ARMLinuxGnuEABI


Ignore:
Timestamp:
Aug 22, 2011 4:53:41 AM (3 years ago)
Author:
kgardas
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • Building/ARMLinuxGnuEABI

    v4 v5  
    2727The following issues will be addressed in future work: 
    2828 * The backend currently breaks with LLVM 2011-08-08 (ghc-stage2 segfaults).  This needs to be investigated.  (Does the LLVM backend work on i386 and x86_64 with LLVM 2011-08-08 — i.e., is this ARM specific?) 
    29  * Use `-optlc=-mattr=+a9,+vfp3` after extending the properly `DriverPipeline` with a specification of the ARM ISA and ISA extensions (instead of using CPP). 
     29 * ~~Use `-optlc=-mattr=+a9,+vfp3` after extending the properly `DriverPipeline` with a specification of the ARM ISA and ISA extensions (instead of using CPP).~~ -- fixed in GHC HEAD as of August 22 2011 
    3030 * The above patch to LLVM needs to be submitted upstream, but only after we have decided on the final register use.