Opened 3 years ago

Closed 3 years ago

Last modified 2 years ago

#9899 closed bug (duplicate)

HEAD: make clean fails to delete libraries/bootstrapping.conf (directory)

Reported by: heisenbug Owned by:
Priority: normal Milestone: 8.0.1
Component: Build System Version: 7.9
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: #9651 Differential Rev(s):
Wiki Page:

Description

"rm" -f libraries/bootstrapping.conf libraries/integer-gmp/cbits/GmpDerivedConstants.h libraries/integer-gmp/include/HsIntegerGmp.h libraries/integer-gmp2/include/HsIntegerGmp.h libraries/base/include/EventConfig.h mk/config.mk.old mk/project.mk.old compiler/ghc.cabal.old includes/GHCConstants.h includes/DerivedConstants.h includes/ghcautoconf.h includes/ghcplatform.h includes/ghcversion.h utils/ghc-pkg/Version.hs compiler/prelude/primops.txt   
rm: cannot remove `libraries/bootstrapping.conf': Is a directory
make[1]: *** [clean_files] Error 1

Then I do

rm -r libraries/bootstrapping.conf
make clean

and this succeeds.

Now I build again:

make

and get an error:

"inplace/bin/ghc-cabal" configure libraries/binary dist-boot "" --with-ghc="/home/ggreif/bin/ghc" --with-ghc-pkg="/home/ggreif/bin/ghc-pkg"  --package-db=/home/ggreif/%NoBackup%/ghc7/ghc-head-x86_64/libraries/bootstrapping.conf --disable-library-for-ghci --enable-library-vanilla --disable-library-profiling --disable-shared --configure-option=CFLAGS=" -fno-stack-protector   " --configure-option=LDFLAGS="   " --configure-option=CPPFLAGS="   " --gcc-options=" -fno-stack-protector       " --configure-option=--with-gmp-includes="/home/ggreif/include"   --constraint "binary == 0.7.2.3"   --constraint "Cabal == 1.21.1.0"   --constraint "hpc == 0.6.0.2"   --constraint "bin-package-db == 0.0.0.0"   --constraint "hoopl == 3.10.0.2"   --constraint "transformers == 0.4.2.0"   --constraint "terminfo == 0.4.0.1" --with-gcc="/usr/bin/gcc" --configure-option=--with-cc="/usr/bin/gcc" --with-ar="/usr/bin/ar" --with-alex="/home/ggreif/bin/alex" --with-happy="/home/ggreif/bin/happy"
Configuring binary-0.7.2.3...
ghc-cabal: '/home/ggreif/bin/ghc-pkg' exited with an error:
ghc-pkg: ghc no longer supports single-file style package databases
(/home/ggreif/%NoBackup%/ghc7/ghc-head-x86_64/libraries/bootstrapping.conf)
use 'ghc-pkg init' to create the database with the correct format.
make[1]: *** [libraries/binary/dist-boot/package-data.mk] Error 1

But the thing is created as a file now:

$ ls -l libraries/bootstrapping.conf
-rw-r--r-- 1 ggreif grp 3 Dec 18 11:17 libraries/bootstrapping.conf

I can recreate it manually:

$ rm libraries/bootstrapping.conf
$ /home/ggreif/bin/ghc-pkg init libraries/bootstrapping.conf
$ ls -ld libraries/bootstrapping.conf
drwxr-xr-x 2 ggreif grp 96 Dec 18 11:23 libraries/bootstrapping.conf

And now make works...

Change History (3)

comment:1 Changed 3 years ago by thoughtpolice

Milestone: 7.10.17.12.1

Moving to 7.12.1 milestone; if you feel this is an error and should be addressed sooner, please move it back to the 7.10.1 milestone.

comment:2 Changed 3 years ago by thomie

Resolution: duplicate
Status: newclosed

This looks like a duplicate of #9651, which was fixed in commit 0899caab400e7a095528ea769a7e93a33717ae72:

Author: Edward Z. Yang <>
Date:   Sat Dec 27 10:57:30 2014 -0500

    Use directory-style database for bootstrapping database
    
    Summary:
    This allows GHC HEAD to be bootstrapped using 7.10.
    
    Signed-off-by: Edward Z. Yang <>
    
    Test Plan: validate
    
    Reviewers: austin
    
    Subscribers: carter, thomie
    
    Differential Revision: https://phabricator.haskell.org/D589
    
    GHC Trac Issues: #9652

comment:3 Changed 2 years ago by thoughtpolice

Milestone: 7.12.18.0.1

Milestone renamed

Note: See TracTickets for help on using tickets.