Opened 3 years ago

Closed 3 years ago

Last modified 2 years ago

#9823 closed bug (duplicate)

--show-iface panics with HEAD

Reported by: jstolarek Owned by:
Priority: normal Milestone: 8.0.1
Component: Driver Version: 7.9
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: GHC doesn't work at all Test Case:
Blocked By: Blocking:
Related Tickets: #9963 Differential Rev(s):
Wiki Page:

Description

Let's say I compile an empty module:

module Foo where

Now, this works:

ghc-stage2 --show-iface Foo.hi

But this panics:

ghc-stage2 Foo.hi --show-iface

ghc-stage2: panic! (the 'impossible' happened)
  (GHC version 7.9.20141120 for x86_64-unknown-linux):
        ghc-stage2: panic! (the 'impossible' happened)
  (GHC version 7.9.20141120 for x86_64-unknown-linux):
        v_unsafeGlobalDynFlags: not initialised

Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug

Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug

Does not happen with 7.8.3. I guess one of recent DynFlags changes must have caused this.

Change History (4)

comment:1 Changed 3 years ago by thomie

comment:2 Changed 3 years ago by thoughtpolice

Milestone: 7.10.17.12.1

Moving to 7.12.1 milestone; if you feel this is an error and should be addressed sooner, please move it back to the 7.10.1 milestone.

comment:3 Changed 3 years ago by thomie

Resolution: duplicate
Status: newclosed

Closing this as a duplicate of #9963, for which I have a fix.

'--show-iface' is a mode flag, just like '--interactive' and '-e', and all usages of invalid (combinations of) mode flag(s) currently panic in HEAD.

Note that the filename should come after the flag, and the error is:

$ ghc-7.8.4 T9963.hi --show-iface
ghc: on the commandline: missing argument for flag: --show-iface
Usage: For basic information, try the `--help' option.

comment:4 Changed 2 years ago by thoughtpolice

Milestone: 7.12.18.0.1

Milestone renamed

Note: See TracTickets for help on using tickets.