Opened 7 years ago

Closed 15 months ago

#964 closed feature request (duplicate)

Cross Compile and Universal Binary

Reported by: shelarcy@… Owned by:
Priority: normal Milestone:
Component: Compiler Version: 6.6
Keywords: Cc: dankna@…
Operating System: MacOS X Architecture: Unknown/Multiple
Type of failure: None/Unknown Difficulty: Project (more than a week)
Test Case: N/A Blocked By:
Blocking: Related Tickets:

Description

GHC supports both PowerPC and Intel Mac. And GHC site provides both version.
But it seems that there is no cross compiling feature and Universal Binary now.

If someone want to build Haskell application as Universal Binary:

  • first he must build Power PC and Intel Mac's binary separately,
  • then merge two binary using lipo command by hand.

http://developer.apple.com/documentation/Darwin/Reference/ManPages/man1/lipo.1.html

And if someone want to build Universal Binary, he must have both machine.

It's not good.

This problem is critical for not only Haskell Application, but also a few Library.

wxHaskell project supplies binary package, that is good for newbie. And it provides make dist command that can build binary package easyly.

But If GHC doesn't support cross compile and Universal binary, it makes hard task that caused by above problems although dependencies has Universal Binary Support.

So I request the feature:

  • support cross compile
  • provide GHC (core and extra) libraries as Universal Binary
  • and Cabal supports to build Universal Binary

under Mac OS X platform.

There are useful information to support Universal Binary.

http://developer.apple.com/documentation/MacOSX/Conceptual/universal_binary/index.html
http://wiki.codeblocks.org/index.php?title=Compiling_Code::Blocks_in_Mac_OS_X

Change History (10)

comment:1 Changed 7 years ago by igloo

  • Test Case set to N/A

comment:2 Changed 7 years ago by igloo

  • Milestone set to _|_

comment:3 Changed 7 years ago by igloo

See also #872, #1540

comment:4 Changed 6 years ago by simonmar

  • Architecture changed from Multiple to Unknown/Multiple

comment:5 Changed 5 years ago by jsnow

Let me just say "me too". I'd like to at least be able to cross-compile from x86 to x86-64 and vice versa.

comment:6 Changed 4 years ago by simonmar

  • Difficulty changed from Project (> 1 week) to Project (more than a week)

comment:7 Changed 4 years ago by igloo

  • Type of failure set to None/Unknown

See also #3814.

comment:8 Changed 3 years ago by dankna

  • Cc dankna@… added

comment:9 Changed 15 months ago by morabbin

Cross-compilation is being actively worked on; close as duplicate of #4163?

comment:10 Changed 15 months ago by simonmar

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.