Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#9531 closed task (fixed)

Implement Prelude.Word Proposal

Reported by: hvr Owned by: hvr
Priority: normal Milestone: 7.10.1
Component: libraries/base Version:
Keywords: Prelude, report-impact Cc: hvr, ekmett
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description (last modified by hvr)

This was proposed on the libraries list and succeeded by vote majority as well as by explicit confirmation from the core libraries committee.

See proposal summary for details.

Change History (5)

comment:1 Changed 4 years ago by Herbert Valerio Riedel <hvr@…>

In 393b820233caa00e428affc28e090b496d181664/ghc:

Re-export Word from Prelude (re #9531)

The original proposal text can be found at

  http://www.haskell.org/pipermail/libraries/2014-August/023491.html

The proposal passed with a clear majority, and was additionally
confirmed by the core libraries committee.

*Compatibility Note*

Only code that imports `Data.Word` for the sole purpose of using `Word`
*and* requires to be `-Werror`-clean (due to `-fwarn-unused-imports`)
is affected by this change.

In order to write warning-free forward/backward compatible against `base`,
a variant of the following CPP-based snippet can be used:

  -- Starting with base>4.7.0 or GHC>7.8 Prelude re-exports 'Word'
  -- The following is needed, if 'Word' is the *only* entity needed from Data.Word
  #ifdef MIN_VERSION_base
  # if !MIN_VERSION_base(4,7,1)
  import Data.Word (Word)
  # endif
  -- no cabal_macros.h -- fallback to __GLASGOW_HASKELL__
  #elif __GLASGOW_HASKELL__ < 709
  import Data.Word (Word)
  #endif

This also updates the haddock submodule in order to avoid a compile warning

comment:2 Changed 4 years ago by hvr

Description: modified (diff)
Resolution: fixed
Status: newclosed

comment:3 Changed 4 years ago by Joachim Breitner <mail@…>

In c9c20d477088a8a7d5747f16afdf0652fba6dadf/nofib:

Hide Word from Prelude

in benchmarks where Word is used. This fixes fall-out from #9531.

comment:4 Changed 4 years ago by Joachim Breitner <mail@…>

In 1719c4207386a42ba4af9914340a6fe60045efe5/ghc:

Update nofib submodule: Hide Word from Prelude

in benchmarks where Word is used. This fixes fall-out from #9531.

comment:5 Changed 4 years ago by hvr

Keywords: report-impact added
Note: See TracTickets for help on using tickets.