#9354 closed bug (invalid)

AtomicPrimops tests failing on 32-bit x86 in ghci

Reported by: tibbe Owned by:
Priority: normal Milestone:
Component: Compiler Version: 7.9
Keywords: Cc: pgj, niklasl
Operating System: Unknown/Multiple Architecture: x86
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:


pgj reports in #9346 that the AtomicPrimops test fails on 32-bit x86, when run under the ghci "way":

$ make TEST=AtomicPrimops WAY=ghci
=====> AtomicPrimops(ghci) 41 of 93 [0, 0, 0] 
cd . && inplace/bin/ghc-stage2 -fforce-recomp -dcore-lint -dcmm-lint -dno-debug-output -no-user-package-db -rtsopts -fno-ghci-history AtomicPrimops.hs --interactive -v0 -ignore-dot-ghci +RTS -I0.1 -RTS   <AtomicPrimops.genscript 1>AtomicPrimops.interp.stdout 2>AtomicPrimops.interp.stderr
Wrong exit code (expected 0 , actual 132 )
fetchAddSubTest: OK


*** unexpected failure for AtomicPrimops(ghci)

Change History (4)

comment:1 Changed 17 months ago by tibbe

  • Cc niklasl added

comment:2 Changed 16 months ago by pgj

Okay, I have tested this with today's version, and it disappeared. Looks like it came up because I did not fully rebuild the sources when I tested my patch for #9346.

Niklas, could you please also confirm this?

comment:3 Changed 16 months ago by niklasl

Everything passes for me!

comment:4 Changed 16 months ago by tibbe

  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.