Opened 8 years ago

Closed 7 years ago

#922 closed bug (worksforme)

ghc-6.5: panic on compile of Language/Haskell/TH/Ppr.hs

Reported by: mcnster Owned by:
Priority: normal Milestone:
Component: Compiler Version: 6.5
Keywords: Cc:
Operating System: Linux Architecture: x86_64 (amd64)
Type of failure: Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description

cd ghc
./darcs-all pull -a    [@ Oct 4 05:50:38 UTC]
autoreconf
./configure
make

<...snip...>

../../compiler/ghc-inplace -H16m -O -package-name  template-haskell-2.0 -O -Rghc-timing -fgenerics  -package base -fgenerics -split-objs    -c Language/Haskell/TH/Ppr.hs -o Language/Haskell/TH/Ppr.o  -ohi Language/Haskell/TH/Ppr.hi
ghc-6.5: panic! (the 'impossible' happened)
  (GHC version 6.5 for x86_64-unknown-linux):
        initC: srt

Change History (2)

comment:1 Changed 8 years ago by simonpj

That's odd -- it compiles here!

Can you ensure that you have done 'make distclean' to start with; and then add -dcore-lint to the library flags.

Thanks

comment:2 Changed 7 years ago by igloo

  • Resolution set to worksforme
  • Status changed from new to closed

In the absence of more information, I think we'll have to assume that this was caused by outdated .hi files being used for imported modules or something.

Note: See TracTickets for help on using tickets.