#9181 closed bug (fixed)

:browse GHC.TypeLits causes panic

Reported by: nomeata Owned by:
Priority: normal Milestone:
Component: Compiler Version: 7.8.2
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: GHCi crash Test Case: T9181
Blocked By: Blocking:
Related Tickets: Differential Revisions:

Description

Upon :browse GHC.TypeLits I get:

ghc-stage2: panic! (the 'impossible' happened)
  (GHC version 7.9.20140606 for x86_64-unknown-linux):
	toIfaceDecl: BuiltInFamTyCon *

Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug

Change History (4)

comment:1 Changed 13 months ago by Joachim Breitner <mail@…>

In b36bc2f5a9757c2b7e6967893cf2883846b8ce91/ghc:

Test case for #9181 (:browse GHC.TypeLits panic)

comment:2 Changed 13 months ago by nomeata

This is caused by

    to_ifsyn_rhs (BuiltInSynFamTyCon {})
      = pprPanic "toIfaceDecl: BuiltInFamTyCon" (ppr tycon)

in tyConToIfaceDecl. Of course we don’t want BuiltInSynFamTyCon in interface files, but we use tyConToIfaceDecl (via pprTyThing) also for pretty-printing. So this function needs to be made “totaler”.

comment:3 Changed 13 months ago by Joachim Breitner <mail@…>

In 96a8980183ed12a354db1b92f271b98bccce9ae8/ghc:

Pretty-print built in synonym families in interfaces

This closes #9181.

comment:4 Changed 13 months ago by nomeata

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.