#9147 closed bug (duplicate)

defining data type in GHC results in ghc: panic! (the 'impossible' happened)

Reported by: tdp93422 Owned by:
Priority: normal Milestone:
Component: GHCi Version: 7.4.1
Keywords: Cc: hvr
Operating System: Linux Architecture: Unknown/Multiple
Type of failure: GHCi crash Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:


vagrant@precise32:~/xml$ ghci -XOverloadedStrings GHCi, version 7.4.1: http://www.haskell.org/ghc/ :? for help Loading package ghc-prim ... linking ... done. Loading package integer-gmp ... linking ... done. Loading package base ... linking ... done. Prelude> data Plant = Plant {common :: String, botanical :: String, zone :: Integer, light :: String, price :: String, availability :: String} deriving (read, show, eq, ord) ghc: panic! (the 'impossible' happened)

(GHC version 7.4.1 for i386-unknown-linux):

nameModule read{tv a9Q}

Please report this as a GHC bug: http://www.haskell.org/ghc/reportabug

Change History (1)

comment:1 Changed 18 months ago by rwbarton

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #5961, fixed since GHC 7.6. deriving (read, show, eq, ord) should be deriving (Read, Show, Eq, Ord).

Note: See TracTickets for help on using tickets.