Opened 12 months ago

Closed 6 months ago

#9141 closed bug (duplicate)

ghc panic linking persistent-sqlite ghc 7.8.2 x86_64-unknown-mingw32 Win 7

Reported by: stuartallenmills Owned by:
Priority: normal Milestone:
Component: Compiler Version: 7.8.2
Keywords: Cc: rcook
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Revisions:

Description

Error occurs attempting to build MFlow. The following is the relevant excerpt:

Loading package persistent-sqlite-1.3.0.5 ... ghc.exe: panic! (the 'impossible' happened)

(GHC version 7.8.2 for x86_64-unknown-mingw32):

loadObj "C:
shared
msys64
home
smills
Hask
mflow
.cabal-sandbox
x86_64-windows-ghc-7.8.2
persistent-sqlite-1.3.0.5
HSpersistent-sqlite-1.3.0.5.o": failed

Please report this as a GHC bug: http://www.haskell.org/ghc/reportabug

....
ghc.exe: Unknown PEi386 section name `.text.unlikely' (while processing: C:\shared\msys64\home\smills\Hask\mflow\.cabal-sandbox\x86_64-windows-ghc-7.8.2\persistent-sqlite-1.3.0.5\HSpersistent-sqlite-1.3.0.5.o)

Change History (2)

comment:1 Changed 12 months ago by rcook

  • Cc rcook added

Bug is probably a duplicate of https://ghc.haskell.org/trac/ghc/ticket/9080.

comment:2 Changed 6 months ago by thomie

  • Resolution set to duplicate
  • Status changed from new to closed

Just like #9116, this is a duplicate of #9080, which has been fixed in 7.8.3.

Note: See TracTickets for help on using tickets.