#9134 closed bug (worksforme)

internal error: PAP object entered!

Reported by: GregWeber Owned by:
Priority: normal Milestone:
Component: GHCi Version: 7.8.2
Keywords: Cc: hvr
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:


<interactive>: internal error: PAP object entered!
    (GHC version 7.8.2 for x86_64_unknown_linux)
    Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug
Aborted (core dumped)

I am doing development in ghci as described here: https://github.com/chrisdone/ghci-reload-demo

I startup ghci from a cabal sandbox with: cabal repl --ghc-options="-O0 -fobject-code"

I see this error every once in a while. I do not have a reproducible test case, but if I see this when working on a smaller project I can try to create one.

Change History (4)

comment:1 Changed 18 months ago by GregWeber

  • Cc hvr added
  • Component changed from Compiler to GHCi
  • Summary changed from ghci: internal error: PAP object entered! to internal error: PAP object entered!

comment:2 Changed 13 months ago by thomie

  • Status changed from new to infoneeded

GregWeber: did you manage to reproduce the error?

comment:3 Changed 13 months ago by GregWeber

No, it may be fixed on 7.8.3 because I have not seen this error in a while. 7.8.3 still crashes when it is used for long enough, but it segfaults without an error message.

comment:4 Changed 13 months ago by thomie

  • Resolution set to worksforme
  • Status changed from infoneeded to closed

If you think you can reproduce the segfault, please open a new ticket for that. Thanks.

Note: See TracTickets for help on using tickets.