#9116 closed bug (fixed)

RTS Linker doesn't recognize .text.unlikely section on Windows

Reported by: niklasl Owned by: simonmar
Priority: normal Milestone:
Component: Runtime System Version: 7.8.2
Keywords: Cc: simonmar, rcook
Operating System: Windows Architecture: Unknown/Multiple
Type of failure: GHC rejects valid program Test Case:
Blocked By: Blocking:
Related Tickets: Differential Revisions:

Description

When trying to use a newer gcc with GHC 7.8.2, some .o files are rejected by the linker for containing a .text.unlikely section with the following message:

Loading package text-1.1.1.2 ... ghc.exe: panic! (the 'impossible' happened)

  (GHC version 7.8.2 for x86_64-unknown-mingw32):

	loadObj "C:\\Niklas\\src\\Idris-dev\\.cabal-sandbox\\x86_64-windows-ghc-7.8.2\\text-1.1.1.2\\HStext-1.1.1.2.o": failed



Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug



ghc.exe: Unknown PEi386 section name `.text.unlikely' (while processing: C:\Niklas\src\Idris-dev\.cabal-sandbox\x86_64-windows-ghc-7.8.2\text-1.1.1.2\HStext-1.1.1.2.o)

This comes from the ocGetNames_PEi386 function in rts/Linker.c. There is a list of section names recognized as code sections at line 4146- in that file. The fix is to add .text.unlikely there, or maybe the right solution is to cast the net wider and accept .text.* as code sections.

Change History (4)

comment:1 Changed 13 months ago by niklasl

Forgot to say that the newer gcc in question was version 4.9.0.

comment:2 Changed 12 months ago by rcook

  • Cc rcook added

Bug is probably a duplicate of https://ghc.haskell.org/trac/ghc/ticket/9080.

comment:3 Changed 12 months ago by niklasl

If it can happen with the mingw distributed with GHC it's quite a bit more urgent to fix. Added a patch to #9080.

comment:4 Changed 10 months ago by niklasl

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.