#9104 closed bug (duplicate)

internal compiler error: Segmentation fault for haskell-src-exts-1.15.0.1

Reported by: mhwombat Owned by:
Priority: normal Milestone:
Component: Compiler Version: 7.8.2
Keywords: Cc:
Operating System: Linux Architecture: x86_64 (amd64)
Type of failure: Compile-time crash Test Case:
Blocked By: Blocking:
Related Tickets: Differential Revisions:

Description

amy@wombat$ cabal --no-require-sandbox install haskell-src-exts-1.15.0.1
Resolving dependencies...
Configuring haskell-src-exts-1.15.0.1...
Building haskell-src-exts-1.15.0.1...
Failed to install haskell-src-exts-1.15.0.1
Last 10 lines of the build log ( /home/amy/.cabal/logs/haskell-src-exts-1.15.0.1.log ):
[22 of 22] Compiling Language.Haskell.Exts ( src/Language/Haskell/Exts.hs, dist/build/Language/Haskell/Exts.o )
[ 1 of 22] Compiling Language.Haskell.Exts.Annotated.Syntax ( src/Language/Haskell/Exts/Annotated/Syntax.hs, dist/build/Language/Haskell/Exts/Annotated/Syntax.p_o )

/tmp/ghc23747_0/ghc23747_3.s:1:0:
     internal compiler error: Segmentation fault
     .section .rodata
     ^
Please submit a full bug report,
with preprocessed source if appropriate.
See <file:///usr/share/doc/gcc-4.8/README.Bugs> for instructions.
cabal: Error: some packages failed to install:
haskell-src-exts-1.15.0.1 failed during the building phase. The exception was:
ExitFailure 1
amy@wombat$ cabal --version
cabal-install version 1.21.0.0
using version 1.21.0.0 of the Cabal library 
amy@wombat$ ghc --version
The Glorious Glasgow Haskell Compilation System, version 7.8.2

Attachments (2)

verboseBuild.txt (9.5 KB) - added by mhwombat 15 months ago.
verbose build (console)
haskell-src-exts-1.15.0.1.log.gz (25.0 KB) - added by mhwombat 15 months ago.
verbose build log

Download all attachments as: .zip

Change History (3)

Changed 15 months ago by mhwombat

verbose build (console)

Changed 15 months ago by mhwombat

verbose build log

comment:1 Changed 14 months ago by rwbarton

  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for the report. This appears to be a duplicate of #8768.

(Note also that it's gcc that's segfaulting here, not ghc! Fun.)

Note: See TracTickets for help on using tickets.