#9083 closed bug (duplicate)

symbol constructors declared prefix missing a leading colon are accepted

Reported by: aavogt Owned by:
Priority: normal Milestone:
Component: Compiler (Parser) Version: 7.8.2
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Revisions:

Description

data M = (++) Int
data N = (⌐) Int
data Ok = (:++) Int -- correctly accepted

I believe ghc should reject M and N. Instead M and N are accepted, but there seems to be no way to use that constructor (besides say a Data instance)

Change History (1)

comment:1 Changed 15 months ago by monoidal

  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for the report; it's a duplicate of #8556.

Note: See TracTickets for help on using tickets.