-XDeriveTraversable should imply -XDeriveFunctor and -XDeriveFoldable
|Reported by:||sjoerd_visscher||Owned by:|
|Type of failure:||None/Unknown||Test Case:|
|Related Tickets:||Differential Rev(s):|
In the discussion in #2953 it was concluded that it would be best to have separate flags for deriving Functor, Foldable and Traversable. I agree with that conclusion, but it seems that it wasn't considered to have -XDeriveTraversable imply -XDeriveFunctor and -XDeriveFoldable. I can't think of a reason not to want that.