Opened 15 months ago

Closed 15 months ago

Last modified 14 months ago

#9045 closed bug (fixed)

threads006: internal error: scavenge_stack: weird activation record found on stack: 415597384

Reported by: simonmar Owned by: simonmar
Priority: highest Milestone: 7.8.3
Component: Runtime System Version: 7.8.2
Keywords: Cc: simonmar
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: Runtime crash Test Case:
Blocked By: Blocking:
Related Tickets: #8866 Differential Revisions:

Description

Found this while working on something else. This is a real bug that can cause random scavenge_stack failures at runtime, and could be the cause of #8866. I have a fix on the way...

Change History (5)

comment:1 Changed 15 months ago by thoughtpolice

Excellent!

comment:2 Changed 15 months ago by Simon Marlow <marlowsd@…>

In ab8bb4893be1896303f30d0f1adff8ea9c2470f6/ghc:

Fix scavenge_stack crash (#9045)

The new stg_gc_prim_p_ll stack frame was missing an info table.  This
is a regression since 7.6, because this stuff was part of a cleanup
that happened in 7.7.

comment:3 Changed 15 months ago by simonmar

  • Status changed from new to merge

comment:4 Changed 15 months ago by thoughtpolice

  • Resolution set to fixed
  • Status changed from merge to closed

Merged.

comment:5 Changed 14 months ago by edsko

For what it's worth, I discovered another fairly minimal example where this happens. It may or may not be useful, mentioning it here just in case. See the Postscript of http://www.well-typed.com/blog/94/.

Note: See TracTickets for help on using tickets.