Opened 9 years ago

Closed 8 years ago

Last modified 7 years ago

#903 closed bug (worksforme)

Bogus out of memory error with -H and -M

Reported by: guest Owned by:
Priority: lowest Milestone:
Component: Runtime System Version: 6.4.2
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: Test Case:
Blocked By: Blocking:
Related Tickets: Differential Revisions:

Description

I've been noticing that -H and/or -M sometimes lead to odd out-of-memory errors (which is a little disappointing because when you have a memory intensive program they can be helpful in tuning performance and footprint).

Here's a repeatable testcase. Compile and run the attached program with -H1.5G and -M1.5G. It will crash with an out-of-memory error even though if you run it without those flags I can't really measure much memory usage at all (via top or time).

Attachments (1)

Debt.hs (286 bytes) - added by guest 9 years ago.

Download all attachments as: .zip

Change History (6)

Changed 9 years ago by guest

comment:1 Changed 9 years ago by guest

I should note that I have observed this issue (and reproduced the result above) with both 6.4.2 and HEAD.

comment:2 Changed 9 years ago by ravi@…

  • Priority changed from normal to lowest

I switched from kernel 2.6.16 (on x86) to kernel 2.6.17 (on x86) and the problem went away. I'm guessing there was some sort of bad interaction that triggered the issue, though I don't know what.

comment:3 Changed 8 years ago by igloo

  • Resolution set to worksforme
  • Status changed from new to closed

I can't reproduce this either.

comment:4 Changed 7 years ago by simonmar

  • Architecture changed from Unknown to Unknown/Multiple

comment:5 Changed 7 years ago by simonmar

  • Operating System changed from Unknown to Unknown/Multiple
Note: See TracTickets for help on using tickets.