#9002 closed bug (invalid)

bus error on sparc in ffi call

Reported by: nomeata Owned by:
Priority: normal Milestone:
Component: Compiler Version: 7.6.3
Keywords: Cc:
Operating System: Linux Architecture: sparc
Type of failure: Runtime crash Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:


Trying to run the test-suite of tls-1.2.6 on sparc with GHC 7.6.3, I get

  Header: [OK, passed 100 tests]
  Handshake: [OK, passed 100 tests]
  Bulk: [OK, passed 100 tests]
  setup: [OK, passed 100 tests]

Program received signal SIGBUS, Bus error.
0x003d8b9c in md5_do_chunk ()
(gdb) bt
#0  0x003d8b9c in md5_do_chunk ()
#1  0x003d9980 in md5_update ()
#2  0x003d1fe0 in saqF_ret ()
#3  0x00da1db8 in StgRun ()
#4  0x00d9f5cc in scheduleWaitThread ()
#5  0x00d9c6e4 in real_main ()
#6  0x00d9c838 in hs_main ()
#7  0x0003b624 in main ()

Any sparc interested people here that can try to reproduce and fix this?

Change History (1)

comment:1 Changed 19 months ago by nomeata

  • Resolution set to invalid
  • Status changed from new to closed

Seems to be a problem in the C code, and not in ffi or GHC (https://github.com/vincenthz/hs-cryptohash/issues/24). Sorry for the noise.

Note: See TracTickets for help on using tickets.