Opened 3 years ago

Closed 16 months ago

#8909 closed bug (duplicate)

ppc dyn executable compiled with ghc-7.8.1 RC2 segfaults

Reported by: juhpetersen Owned by:
Priority: normal Milestone:
Component: Compiler Version: 7.8.1-rc2
Keywords: Cc: ptrommler@…
Operating System: Unknown/Multiple Architecture: powerpc
Type of failure: Runtime crash Test Case:
Blocked By: Blocking:
Related Tickets: 8024 Differential Rev(s):
Wiki Page:

Description

I built ghc-7.8.1 RC2 on ppc Fedora 21 Development with ghc-7.6.3.

When I try to run dynamically linked "helloworld", it segfaults. I don't have direct access yet to a ppc box to investigate further. I guess something about the use of shared libraries on ppc is not working properly.

$ cat > hello.hs
main = putStrLn "hi"
$ ghc -dynamic hello.hs
$ ./hello
Segmentation fault      (core dumped) ./hello

Change History (6)

comment:1 Changed 3 years ago by trommler

Cc: ptrommler@… added

Here is a stack trace:

[   34s] Program received signal SIGSEGV, Segmentation fault.
[   34s] 0x0f77e05c in stg_enter_info ()
[   34s]    from /usr/lib/ghc-7.8.0.20140228/rts-1.0/libHSrts-ghc7.8.0.20140228.so
[   34s] (gdb) #0  0x0f77e05c in stg_enter_info ()
[   34s]    from /usr/lib/ghc-7.8.0.20140228/rts-1.0/libHSrts-ghc7.8.0.20140228.so
[   34s] #1  0x0f759510 in scheduleWaitThread ()
[   34s]    from /usr/lib/ghc-7.8.0.20140228/rts-1.0/libHSrts-ghc7.8.0.20140228.so
[   34s] #2  0x0f7625b4 in rts_evalLazyIO ()
[   34s]    from /usr/lib/ghc-7.8.0.20140228/rts-1.0/libHSrts-ghc7.8.0.20140228.so
[   34s] #3  0x0f764324 in hs_main ()
[   34s]    from /usr/lib/ghc-7.8.0.20140228/rts-1.0/libHSrts-ghc7.8.0.20140228.so
[   34s] #4  0x100014dc in main ()

comment:2 Changed 3 years ago by slyfox

I think it's a manifestation of #8024 (and #8857).

Can you try to apply a patch on top of 7.8.3 from

https://phabricator.haskell.org/D177

(or just try -HEAD) and see if it helps?

comment:3 Changed 2 years ago by thomie

Status: newinfoneeded

comment:4 Changed 2 years ago by slyfox

Resolution: fixed
Status: infoneededclosed

Mark as duplicate of #8024

comment:5 Changed 16 months ago by thomie

Resolution: fixed
Status: closednew

comment:6 Changed 16 months ago by thomie

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.