#8906 closed bug (duplicate)

rewrite arrow form in type signature sometimes leads to exception, sometimes not

Reported by: thaumkid Owned by:
Priority: low Milestone:
Component: GHCi Version: 7.6.3
Keywords: Cc: hvr
Operating System: Windows Architecture: x86_64 (amd64)
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Revisions:

Description

Seems like the arrow form in signatures should either be restricted further or made more flexible.

> let a = id :: ((->) a) a
> a 2
*** Exception: expectJust cpeBody:collect_args
> :t a
a :: (->) a a
> let a = id :: (->) a a
> a 2
2
> :t a
a :: a -> a

Change History (1)

comment:1 Changed 15 months ago by monoidal

  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for the report; it's a duplicate of #7903/#8492.

Note: See TracTickets for help on using tickets.