#8803 closed bug (duplicate)

ghc panic ((!!): index too large) when building some packages

Reported by: joelteon Owned by:
Priority: normal Milestone:
Component: Compiler Version: 7.8.1-rc1
Keywords: Cc:
Operating System: MacOS X Architecture: x86_64 (amd64)
Type of failure: Compile-time crash Test Case:
Blocked By: Blocking:
Related Tickets: Differential Revisions:

Description

I'm not 100% sure what the cause of this is, because I can't get a reproducible test case.

If I try to build postgresql-simple, this is the output from cabal (with -v3): https://gist.github.com/anonymous/bda9095cee1eda5640c0

Wondered whether it was related to hs-boot files, but I cannot reproduce the error with the basic example from http://www.haskell.org/ghc/docs/7.0.3/html/users_guide/separate-compilation.html.

Change History (1)

comment:1 Changed 13 months ago by thoughtpolice

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #8743 which is fixed - thanks!

Note: See TracTickets for help on using tickets.