Opened 20 months ago

Closed 20 months ago

Last modified 20 months ago

#8788 closed task (invalid)

Remove old comment

Reported by: Tarrasch Owned by: simonmar
Priority: lowest Milestone:
Component: Runtime System Version: 7.6.3
Keywords: Cc: simonmar
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):


See attachment

Attachments (1)

remove-comment.patch (1.0 KB) - added by Tarrasch 20 months ago.

Download all attachments as: .zip

Change History (6)

Changed 20 months ago by Tarrasch

comment:1 Changed 20 months ago by crockeea

  • difficulty changed from Unknown to Easy (less than 1 hour)

comment:2 Changed 20 months ago by simonmar

doesn't the comment still apply?

comment:3 Changed 20 months ago by Tarrasch

Did you see my comment in the commit message? I reproduce it here:

There's no way to reuse the code for say [P, P] and [P, N], since the juxtaposing of code and data when compiling with TABLES_NEXT_TO_CODE.

Well, I guess the comment still applies if you don't compile with TABLES_NEXT_TO_CODE.

Here is some more elaboration: If you intend to share the code for two different tables, you do that by letting the "code-entry-pointer" in the two tables point to the same code. But there's no such "code-entry-pointer" field with TABLES_NEXT_TO_CODE.

Last edited 20 months ago by Tarrasch (previous) (diff)

comment:4 Changed 20 months ago by simonmar

  • Resolution set to invalid
  • Status changed from new to closed

The code fragments that the comment is referring to don't have info tables (stg_ap_stk and stg_ap_stk_save).

comment:5 Changed 20 months ago by Tarrasch

Whoups, my bad.

Note: See TracTickets for help on using tickets.