Opened 2 months ago

Closed 2 months ago

#8786 closed bug (fixed)

libraries/primitive build failure on Solaris 10

Reported by: kgardas Owned by:
Priority: normal Milestone: 7.8.1
Component: libraries (other) Version: 7.8.1-rc1
Keywords: Cc:
Operating System: Solaris Architecture: x86_64 (amd64)
Type of failure: Building GHC failed Difficulty: Easy (less than 1 hour)
Test Case: Blocked By:
Blocking: Related Tickets:

Description

Solaris 10 is distributed with GNU C 3.4.3 compiler. This compiler does not support -ftree-vectorize command-line option and so its cc1 process fails on it which also mean that ghc-cabal fails compiling primitive package. The solution is simple to remove the -ftree-vectorize for solaris although it'll penalize Solaris 11 which is distributed with GNU C 4.6.2. I've solved that and provided a patch to primitive project in a pull request here: https://github.com/haskell/primitive/pull/6
I've entered the bug here to also track it and lobby for this issue to be solved for 7.8.1 release.

Change History (3)

comment:1 Changed 2 months ago by kgardas

  • Status changed from new to patch

My patch was merged upstream. I'm switching state to patch to show that it's possible now to merge it from upstream to GHC HEAD

comment:2 Changed 2 months ago by thoughtpolice

  • Status changed from patch to merge

comment:3 Changed 2 months ago by thoughtpolice

  • Resolution set to fixed
  • Status changed from merge to closed

Herbert merged this into the 7.8 branch.

Note: See TracTickets for help on using tickets.