Opened 4 years ago

Closed 4 years ago

#8747 closed bug (duplicate)

GHC 7.4.1 ghc: panic! (the 'impossible' happened)

Reported by: codygman Owned by:
Priority: normal Milestone:
Component: GHCi Version: 7.4.1
Keywords: Cc: hvr
Operating System: Linux Architecture: x86_64 (amd64)
Type of failure: GHCi crash Test Case:
Blocked By: Blocking:
Related Tickets: #5961 Differential Rev(s):
Wiki Page:

Description

I was just trying to create the records in the all about monads tutorial and after changing my code to:

import Data.Maybe (Maybe(Nothing,Just))

data Gender = M | F
data Sheep = Sheep (Gender) (Maybe Sheep) (Maybe Sheep) deriving (show)
main = undefined

I got the following error:

*Main> :r
[1 of 1] Compiling Main             ( Main.hs, interpreted )
ghc: panic! (the 'impossible' happened)
  (GHC version 7.4.1 for x86_64-unknown-linux):
	nameModule show{tv aD4}

Please report this as a GHC bug: http://www.haskell.org/ghc/reportabug

I've attached my entire ghci log for completeness sake. I'm using debian stable and kernel 3.11-0.bpo.2-amd64.

Attachments (1)

ghcilog.txt (10.5 KB) - added by codygman 4 years ago.
full log of ghci activity before ghci 'impossible' crash

Download all attachments as: .zip

Change History (2)

Changed 4 years ago by codygman

Attachment: ghcilog.txt added

full log of ghci activity before ghci 'impossible' crash

comment:1 Changed 4 years ago by nomeata

Resolution: duplicate
Status: newclosed

This is a duplicate of #5961 and fixed in GHC 7.6. Make sure you write deriving (Show)!

Note: See TracTickets for help on using tickets.