#8744 closed bug (fixed)

"Thread-local storage not supported" for Mac

Reported by: goldfire Owned by:
Priority: normal Milestone: 7.8.1
Component: Compiler Version: 7.8.1-rc1
Keywords: Cc:
Operating System: MacOS X Architecture: x86_64 (amd64)
Type of failure: Building GHC failed Test Case:
Blocked By: Blocking:
Related Tickets: Differential Revisions:

Description

On a fresh clone of HEAD, building eventually gets me

"inplace/bin/ghc-stage1" -optc-Wall -optc-Wextra -optc-Wstrict-prototypes -optc-Wmissing-prototypes -optc-Wmissing-declarations -optc-Winline -optc-Waggregate-return -optc-Wpointer-arith -optc-Wmissing-noreturn -optc-Wnested-externs -optc-Wredundant-decls -optc-Iincludes -optc-Iincludes/dist -optc-Iincludes/dist-derivedconstants/header -optc-Iincludes/dist-ghcconstants/header -optc-Irts -optc-Irts/dist/build -optc-DCOMPILING_RTS -optc-fno-strict-aliasing -optc-fno-common -optc-DDTRACE -optc-O2 -optc-fomit-frame-pointer -optc-DRtsWay=\"rts_thr\" -optc-funroll-loops -static -optc-DTHREADED_RTS  -H64m -O -fasm -Iincludes -Iincludes/dist -Iincludes/dist-derivedconstants/header -Iincludes/dist-ghcconstants/header -Irts -Irts/dist/build -DCOMPILING_RTS -package-name rts -dcmm-lint  -DDTRACE     -i -irts -irts/dist/build -irts/dist/build/autogen -Irts/dist/build -Irts/dist/build/autogen           -O2    -c rts/sm/Evac.c -o rts/dist/build/sm/Evac.thr_o

In file included from rts/sm/Evac.c:21:0: 

rts/sm/GCTDecl.h:71:0:
     error: thread-local storage not supported for this target

I'm on Mac OS 10.8.5, Xcode 4.6.1 (4H512), bootstrapping from 7.6.3, with BuildFlavour = devel2.

With this report, my build is dead in the water.

(Separately, Trac doesn't have an option for reporting a bug in version 7.9!)

Change History (6)

comment:1 Changed 18 months ago by thoughtpolice

Can you try now? I just pushed 298a25bdf and b4eb630c74 to HEAD which might fix this for you.

comment:2 Changed 18 months ago by goldfire

The build (with your commits) is working on a Mac with a slightly different setup. Will test on the original failing machine this weekend.

comment:3 Changed 18 months ago by MtnViewMark

I tried building last night with ghc-7.8 tag with the those two patches cherry picked on top. It worked!

Mac OS X 10.8.5 w/Xcode 4.5.2

After I cherry picked, I had to do:

make maintainer-clean
./boot
./configure
make

I'm never sure if that is the right sequence after a pull like this...

comment:4 Changed 18 months ago by goldfire

  • Status changed from new to merge

Yes, things worked for me as well. I'll close the ticket. Thanks!

comment:5 Changed 18 months ago by thoughtpolice

  • Milestone set to 7.8.1

comment:6 Changed 18 months ago by thoughtpolice

  • Resolution set to fixed
  • Status changed from merge to closed

These are merged.

Note: See TracTickets for help on using tickets.