Opened 3 months ago

Closed 5 weeks ago

#8693 closed bug (duplicate)

dyn way broken on powerpc

Reported by: trommler Owned by:
Priority: normal Milestone:
Component: Compiler Version: 7.7
Keywords: Cc:
Operating System: Linux Architecture: powerpc
Type of failure: Building GHC failed Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description

Building GHC with dynamic enabled I see lots of the following errors on powerpc (32 bit):

[ 1679s] /tmp/ghc19669_0/ghc19669_6.s: Assembler messages:
[ 1679s] 
[ 1679s] /tmp/ghc19669_0/ghc19669_6.s:39625:0:
[ 1679s]      Error: operand out of range (0x000000000000b700 is not between 0xffffffffffff8000 and 0x0000000000007fff)
...
[ 1679s] /tmp/ghc19669_0/ghc19669_6.s:43936:0:
[ 1679s]      Error: operand out of range (0x0000000000008018 is not between 0xffffffffffff8000 and 0x0000000000007fff)
[ 1679s] make[1]: *** [libraries/time/dist-install/build/Data/Time/Format.o] Error 1
[ 1679s] make[1]: *** Deleting file `libraries/time/dist-install/build/Data/Time/Format.o'

Change History (1)

comment:1 Changed 5 weeks ago by trommler

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #7830 and fixed there. Closing the ticket.

Note: See TracTickets for help on using tickets.