Opened 19 months ago

Closed 9 months ago

#8688 closed bug (worksforme)

internal error: stg_ap_p_ret

Reported by: massysett Owned by:
Priority: normal Milestone:
Component: Compiler Version: 7.6.3
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Revisions:

Description

When in GHCi I get:

<interactive>: internal error: stg_ap_p_ret

(GHC version 7.6.3 for x86_64_unknown_linux) Please report this as a GHC bug: http://www.haskell.org/ghc/reportabug

There is probably something wrong with the FFI binding I am testing; under other circumstances I get a segfault. But since I was asked to report this, here I am. Let me know if I can provide anything else.

Change History (2)

comment:1 Changed 19 months ago by monoidal

Could you give a way to reproduce it - ideally a runnable file? Or, try your code with GHC HEAD?

comment:2 Changed 9 months ago by thomie

  • Resolution set to worksforme
  • Status changed from new to closed

massysett: please re-open if you run into this problem again, ideally with a description on how to reproduce it.

Note: See TracTickets for help on using tickets.