#8667 closed bug (duplicate)

sync-all doesn't work properly if you run from a fork on github

Reported by: schyler Owned by: hvr
Priority: normal Milestone:
Component: Trac & Git Version: 7.6.3
Keywords: sync-all Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):


The intuitive behaviour when working with projects on github is to make your own fork so that you can use the online interface (or GitHub for {windows,osx} apps).

One would assume that this behaviour was endorsed because of the ~130 forks to the ghc repo, however forking the repo actually causes ./sync-all to stop working (it asks for a username and password to whomever@ github.com). It seems the only way for a person to work with the project from github is to clone directly from the original repo.

This sounds like a bug.

Change History (2)

comment:1 Changed 21 months ago by schyler

Steps to reproduce:

  • fork
  • clone
  • attempt to run ./sync-all get

comment:2 Changed 16 months ago by thomie

  • Keywords sync-all added
  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #8379. Please reopen that one if you're still having problems.

Note: See TracTickets for help on using tickets.