Opened 9 years ago

Closed 9 years ago

Last modified 6 years ago

#866 closed bug (invalid)

Building unregistarized version

Reported by: kyukhin Owned by:
Priority: high Milestone:
Component: Build System Version: 6.4
Keywords: unregisterize Cc:
Operating System: Linux Architecture: x86
Type of failure: Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):


Hi, all! I am trying to create unregisterized build of GHC 6.4. In distrib/cross-port I changed path and execute this script.

After prints ==fptools== make all -wr;

in /home/kyukhin/work/ghx-6.4/ghc/compiler

builds says nothing at all (I'm wat for two weeks )) ) System: Ubuntu Dapper Drake make - 3.81beta4

Also I tryed to do it on some other machines ( Xeon servers if Red Hat Enterprise). And got the same result.

Can you explain, is it a bug, or my mistake?

Best Regards, Yukhin Kirill (kirill.yukhin@…)

Change History (2)

comment:1 Changed 9 years ago by simonmar

  • Resolution set to invalid
  • Status changed from new to closed

You have probably encountered the problem with GNU make that we worked around recently (or maybe it was our problem, I'm still not entirely sure).

First of all, you should use GHC 6.4.2 at least for bootstrapping.

Secondly, I don't think we recommend using the cross-port script. Full instructions for bootstrapping are in the Building Guide:

Finally, I can't believe you waited two weeks for some output!

If you still run into problems, submit another report.

comment:2 Changed 6 years ago by simonmar

  • difficulty changed from Easy (1 hr) to Easy (less than 1 hour)
Note: See TracTickets for help on using tickets.