#8637 closed bug (duplicate)

Infix declaration on operators ending on backslash

Reported by: jcristovao Owned by:
Priority: normal Milestone:
Component: Compiler Version: 7.7
Keywords: Cc:
Operating System: Linux Architecture: x86_64 (amd64)
Type of failure: GHC rejects valid program Test Case:
Blocked By: Blocking:
Related Tickets: Differential Revisions:

Description

Hi,

I was trying the latest GHC Head (version 7.7.20131227), when I noticed a regression. I don't know if this is intended behaviour or not. This compiled ok under 7.6.3

(?&&\) :: (Monoid a) => a -> (a -> Bool) -> a
(?&&\) value f = if f value then value else mempty
infixl 1 ?&&\

Under 7.7, the infixl declaration only works if I double escape it.

infixl 1 ?&&\\

Is this intended?

Change History (1)

comment:1 Changed 17 months ago by jcristovao

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.