#8632 closed bug (duplicate)

ghc: panic! (the 'impossible' happened)

Reported by: jdoliner Owned by:
Priority: normal Milestone:
Component: Compiler Version: 7.4.1
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: x86_64 (amd64)
Type of failure: Compile-time crash Test Case:
Blocked By: Blocking:
Related Tickets: Differential Revisions:

Description

I got this message when trying to compile. It appears to be reproducible. Also I realize this is an outdate version of GHC so I'm going to update and see if it fixes itself.

(GHC version 7.4.1 for x86_64-unknown-linux):

compiler/rename/RnSource.lhs:429:14-81: Irrefutable pattern failed for pattern Data.Maybe.Just (inst_tyvars,

_, SrcLoc.L _ cls, _)

Change History (1)

comment:1 Changed 19 months ago by goldfire

  • Resolution set to duplicate
  • Status changed from new to closed

It looks like you forgot to attach the code that causes the error. In any case, this looks like the same problem as #7094, which was not reproducible in 7.6.x. If you find otherwise, please re-open the ticket.

Thanks for reporting!

Note: See TracTickets for help on using tickets.