Opened 8 years ago

Closed 8 years ago

#858 closed bug (invalid)

-fPIC on x86 and x86_64

Reported by: roberto@… Owned by:
Priority: normal Milestone:
Component: Compiler Version: 6.4.2
Keywords: fPIC dynamic Cc:
Operating System: Linux Architecture: x86
Type of failure: Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description

I've read optimistic messages claiming that fPIC support for x86 was about to be ready. That was in 2004.
The latest info I could find about the issue was provided by Wolfgang Thaller at http://haskell.cs.yale.edu/hawiki/DynamicLinkingInGhc
That is dated early 2005.

Any progress since then? It would be nice to have a clue on when this feature will be working.

BTW, I don't understand why gcc -fPIC on ghc-produced c files doesn't work.

Change History (2)

comment:1 Changed 8 years ago by wolfgang

It is "about to be ready". It's only currently stalled because I've had no time to continue my work, but I expect to have more time again in September.

comment:2 Changed 8 years ago by simonmar

  • Resolution set to invalid
  • Status changed from new to closed

Not a bug. -fPIC is definitely on the agenda, though.

The reason why you can't just use -fPIC on the C files is because we post-process the .s file generated by gcc, and the post-processor can't handle PIC for various hard-to-fix reasons. It's likely that when we get -fPIC working, it will not be compatible with -fvia-C.

However, -fPIC should work fine with an unregisterised build (I haven't tried this, though).

Note: See TracTickets for help on using tickets.