Opened 16 months ago

Closed 4 months ago

#8568 closed bug (duplicate)

internal error: allocation of ... bytes too large

Reported by: mojojojo Owned by:
Priority: normal Milestone:
Component: Compiler Version: 7.6.3
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: Runtime crash Test Case:
Blocked By: Blocking:
Related Tickets: #9647 Differential Revisions:

Description (last modified by thomie)

Running the following program after normal compilation:

import GHC.DataSize
import qualified Data.HashTable.IO as HT
import Control.Monad
main = do
  t <- HT.new :: IO (HT.BasicHashTable Int Char)
  forM_ [0..100000] $ \i -> HT.insert t i 'a'
  recursiveSize t
  return ()

results in the following error:

internal error: allocation of 1208480 bytes too large (GHC should have complained at compile-time)
    (GHC version 7.8.3 for x86_64_unknown_linux)

To reproduce, first: cabal install ghc-datasize hashtables.

Change History (3)

comment:1 Changed 5 months ago by MikolajKonarski

comment:2 Changed 4 months ago by thomie

  • Description modified (diff)
  • Type of failure changed from None/Unknown to Runtime crash

Can not install dependencies with ghc-7.9.20141115, so don't know if this fixed in HEAD.

comment:3 Changed 4 months ago by Yuras

  • Resolution set to duplicate
  • Status changed from new to closed

Seems to be a duplicate of #4505. Please reopen if you disagree.

Note: See TracTickets for help on using tickets.