Opened 5 months ago

Closed 5 months ago

#8546 closed bug (duplicate)

Panic during cabal build with profiling enabled.

Reported by: Mokosha Owned by:
Priority: normal Milestone:
Component: Compiler Version: 7.6.3
Keywords: cabal sandbox Cc:
Operating System: Windows Architecture: x86
Type of failure: Compile-time crash Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets: 7056

Description

I had been recently using cabal-dev for my development work. Someone suggested I switch over to the new cabal 1.18 on #haskell. After doing so, some projects do not seem to build anymore. I'm not an experienced Haskell developer, so I'm not sure how to go about debugging such a problem. I've included the output of the install command.

Pavel@ZOMBIE-POWER ~/Projects/Lambency/src
$ cabal install -p
Resolving dependencies...
Configuring bindings-GLFW-3.0.3.1...
Building bindings-GLFW-3.0.3.1...
Preprocessing library bindings-GLFW-3.0.3.1...
[1 of 1] Compiling Bindings.GLFW    ( dist\dist-sandbox-2b66993e\build\Bindings\GLFW.hs, dist\dist-sandbox-2b66993e\build\Bindings\GLFW.o )
[1 of 1] Compiling Bindings.GLFW    ( dist\dist-sandbox-2b66993e\build\Bindings\GLFW.hs, dist\dist-sandbox-2b66993e\build\Bindings\GLFW.p_o )
In-place registering bindings-GLFW-3.0.3.1...
Installing library in
D:\MinGW\msys\1.0\home\Pavel\Projects\Lambency\build\i386-windows-ghc-7.6.3\bindings-GLFW-3.0.3.1
Registering bindings-GLFW-3.0.3.1...
Installed bindings-GLFW-3.0.3.1
Configuring GLFW-b-1.4.1...
Building GLFW-b-1.4.1...
Preprocessing library GLFW-b-1.4.1...
[1 of 3] Compiling Graphics.UI.GLFW.Types ( Graphics\UI\GLFW\Types.hs, dist\dist-sandbox-2b66993e\build\Graphics\UI\GLFW\Types.o )
Loading package ghc-prim ... linking ... done.
Loading package integer-gmp ... linking ... done.
Loading package base ... linking ... done.
Loading package bindings-DSL-1.0.20 ... linking ... done.
Loading package bindings-GLFW-3.0.3.1 ... ghc.exe: Unknown PEi386 section name `.drectve' (while processing: D:\MinGW\msys\1.0\home\Pavel\Projects\Lambency\build\i386-windows-ghc-7.6.3\bindings-GLFW-3
.0.3.1\libHSbindings-GLFW-3.0.3.1.a)
ghc.exe: panic! (the 'impossible' happened)
  (GHC version 7.6.3 for i386-unknown-mingw32):
        loadArchive "D:\\MinGW\\msys\\1.0\\home\\Pavel\\Projects\\Lambency\\build\\i386-windows-ghc-7.6.3\\bindings-GLFW-3.0.3.1\\libHSbindings-GLFW-3.0.3.1.a": failed

Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug

Failed to install GLFW-b-1.4.1
cabal.exe: Error: some packages failed to install:
GLFW-b-1.4.1 failed during the building phase. The exception was:
ExitFailure 1

Change History (1)

comment:1 Changed 5 months ago by Mokosha

  • Resolution set to duplicate
  • Status changed from new to closed

Seems to be a duplicate of bug 7056

Note: See TracTickets for help on using tickets.