[patch] comments outdated
|Reported by:||errge||Owned by:|
|Type of failure:||None/Unknown||Difficulty:||Easy (less than 1 hour)|
|Test Case:||Blocked By:|
Description (last modified by hvr)
During working on GHC, I found these outdated comments and function names.
The ForPlugins renaming in compiler/main/DynamicLoading.hs is motivated by the fact that change [57d67983] crippled the function in a way that now it can only be used while handling Plugins. Therefore the name should warn the programmer to this fact.
The hptInstances comment has also been outdated, when someone needed to add the ModuleName -> Bool predicate to use this same function for handling ghc and ghci with shared code.
The attached patch is trivial renames/comments.