Opened 5 years ago

Closed 4 years ago

#8415 closed bug (worksforme)

GHC bug using darcs on Kubuntu 13.04

Reported by: JoeAquilina Owned by: simonmar
Priority: normal Milestone:
Component: Runtime System Version: 7.6.3
Keywords: Cc: simonmar
Operating System: Unknown/Multiple Architecture: x86_64 (amd64)
Type of failure: Runtime crash Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description (last modified by hvr)

I was trying to push a Darcs patch when it failed with a GHC error. This is the text of the error message on the console:

darcs: internal error: evacuate: strange closure type 536064
    (GHC version 7.6.2 for x86_64_unknown_linux)
    Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug
Aborted (core dumped)

Not sure if this is exactly what is required when reporting a bug, I am very new to this and am unsure of the procedures involved regarding GHC bug reporting.

Thanks in advance.

Change History (2)

comment:1 Changed 5 years ago by hvr

Cc: simonmar added
Component: CompilerRuntime System
Description: modified (diff)
Owner: set to simonmar
Type of failure: None/UnknownRuntime crash

comment:2 Changed 4 years ago by thomie

Resolution: worksforme
Status: newclosed

Thank you for the report. A lot has changed since you opened it though, so I'm going to close this ticket for now. If you do experience ghc panics in relation to darcs again, don't hesitate to re-open. Please try to describe the steps necessary for us to reproduce the problem, see ReportABug.

Note: See TracTickets for help on using tickets.