Opened 8 years ago

Closed 8 years ago

Last modified 6 years ago

#819 closed bug (duplicate)

Uncaught kind error leads to the 'impossible' happening

Reported by: sweirich@… Owned by:
Priority: normal Milestone:
Component: Compiler Version: 6.4
Keywords: Cc:
Operating System: MacOS X Architecture: Unknown/Multiple
Type of failure: Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description

data F c a = F (c a)

data Val c a = Val (F c) a --- should produce a kind error but doesn't

t = Val (F [True]) False --- here we get the impossible


dhcp38-137:~/writing/exrep sweirich$ ghci test.hs

_ _ _

/ _ \ /\ /\/ (_)

/ /_\ /_/ / / | | GHC Interactive, version 6.4, for Haskell 98.

/ /_
/ / /_| | http://www.haskell.org/ghc/
\/\/ /_/\/|_| Type :? for help.

Loading package base-1.0 ... linking ... done.
Compiling Main ( test.hs, interpreted )
ghc-6.4: panic! (the `impossible' happened, GHC version 6.4):

Unify.unifyTauTyLists: mismatched type lists!

Please report it as a compiler bug to glasgow-haskell-bugs@…,
or http://sourceforge.net/projects/ghc/.

Change History (2)

comment:1 Changed 8 years ago by simonpj

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #818

comment:2 Changed 6 years ago by simonmar

  • Architecture changed from Unknown to Unknown/Multiple
Note: See TracTickets for help on using tickets.