Opened 12 months ago

Closed 8 months ago

Last modified 8 months ago

#7884 closed bug (invalid)

Cannot build hedgewars with new haskell 7.6

Reported by: LocutusOfBorg Owned by:
Priority: normal Milestone:
Component: Compiler Version: 7.6.2
Keywords: regression Cc:
Operating System: Linux Architecture: arm
Type of failure: Compile-time crash Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description

Hi All, I post here since this bug *CAN* be a regression between haskell 7.4 and 7.6.

Please look at this log
https://buildd.debian.org/status/fetch.php?pkg=hedgewars&arch=armhf&ver=0.9.18-0.3&stamp=1367518566
Everything is fine with haskell 7.4

and this one
https://launchpadlibrarian.net/138989726/buildlog_ubuntu-saucy-armhf.hedgewars_0.9.18-0.3_FAILEDTOBUILD.txt.gz

this seems to be an uncorrent link with the new haskell

Change History (3)

comment:1 Changed 8 months ago by tab

  • Difficulty set to Unknown

it seems to fail duing the building of the *pascal* part of hedgewar. The haskell part (hedgewar-server) built successfully in both case according to the log. Someone should close this as invalid (i would do it, but not enough privileges).

comment:2 Changed 8 months ago by LocutusOfBorg

  • Resolution set to invalid
  • Status changed from new to closed

comment:3 Changed 8 months ago by LocutusOfBorg

Yeah thanks for reminding to me.

I fixed by manually adding libgcc_s to the linker.

closing, thanks

Note: See TracTickets for help on using tickets.