#7811 closed bug (worksforme)

intermittent 'unexpected' results of test ghcpkg01

Reported by: nfrisby Owned by: igloo
Priority: normal Milestone: 7.8.1
Component: ghc-pkg Version: 7.6.2
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description

I get this unexpected error from ghcpkg01

Actual stderr output differs from expected:
...
+WARNING: cache is out of date: localXXX/package.cache
+  use 'ghc-pkg recache' to fix.

when running the full suite, but cannot reproduce it when running just that test; it passes when run individually.

(This was also reported in #5503.)

Change History (2)

comment:1 Changed 13 months ago by igloo

  • Difficulty set to Unknown
  • Milestone set to 7.8.1
  • Owner set to igloo

I'll see if I can work out what's going on.

comment:2 Changed 10 months ago by igloo

  • Resolution set to worksforme
  • Status changed from new to closed

I can't reproduce the problem, and can't see anything obviously wrong. I can't do anything more without more information, so closing this ticket.

Note: See TracTickets for help on using tickets.