Opened 2 years ago

Closed 2 years ago

#7691 closed bug (worksforme)

ghc.exe: internal error: evacuate: strange closure type 48880

Reported by: Henk-Jan Owned by:
Priority: normal Milestone:
Component: Compiler Version: 7.4.2
Keywords: Cc: hjgtuyl@…
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: Compile-time crash Test Case:
Blocked By: Blocking:
Related Tickets: Differential Revisions:

Description

While trying to install haskell-src-exts-1.13.5, the following message was displayed: ghc.exe: internal error: evacuate: strange closure type 48880

(GHC version 7.4.2 for i386_unknown_mingw32) Please report this as a GHC bug: http://www.haskell.org/ghc/reportabug

See the attached file for all messages. I issued command

cabal install haskell-src-exts-1.13.5

after this; the command was successful.

Attachments (1)

GHC-bug.txt (17.3 KB) - added by Henk-Jan 2 years ago.
Shell output

Download all attachments as: .zip

Change History (5)

Changed 2 years ago by Henk-Jan

Shell output

comment:1 Changed 2 years ago by Henk-Jan

  • Cc hjgtuyl@… added

comment:2 Changed 2 years ago by simonmar

  • difficulty set to Unknown
  • Status changed from new to infoneeded

Is it repeatable? If not, probably a hardware glitch.

comment:3 Changed 2 years ago by Henk-Jan

I cannot reproduce the error; I suppose you can close the ticket.

comment:4 Changed 2 years ago by igloo

  • Resolution set to worksforme
  • Status changed from infoneeded to closed
Note: See TracTickets for help on using tickets.