Opened 8 years ago

Closed 8 years ago

Last modified 4 years ago

#769 closed bug (fixed)

Heap profiling: time tag format

Reported by: guest Owned by:
Priority: normal Milestone:
Component: Compiler Version: 6.4.2
Keywords: heap profiling Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: Difficulty: Easy (less than 1 hour)
Test Case: Blocked By:
Blocking: Related Tickets:

Description

If you enable heap profiling and then use hp2ps to generate a graph it occasionally reports records out of order. The reason is the time tag at the beginning and end of each record, which is printed with two decimal places. When the time reaches an integer number of seconds it is printed as e.g. 6.100 instead of 7.00. hp2ps interprets this as 6.1 seconds.

This applies to at least 6.4, 6.4.1 and 6.4.2. I've seen it on Windows, but I expect it applies to other OSes as well.

Change History (5)

comment:1 Changed 8 years ago by guest

I note that this is a dupe of 664. But that was marked as fixed. I'm afraid its not fixed.

comment:2 Changed 8 years ago by simonmar

  • Resolution set to fixed
  • Status changed from new to closed

Thanks. #664 was fixed, but the fix was not merged into the 6.4 branch (an oversight on my part).

comment:3 Changed 6 years ago by simonmar

  • Architecture changed from Unknown to Unknown/Multiple

comment:4 Changed 6 years ago by simonmar

  • Operating System changed from Multiple to Unknown/Multiple

comment:5 Changed 4 years ago by simonmar

  • Difficulty changed from Easy (1 hr) to Easy (less than 1 hour)
Note: See TracTickets for help on using tickets.